Xcode 4.3インストール後、xcodebuildが動作しない場合の修復方法

コマンドラインでXcodeのプロジェクトをビルドするxcodebuildコマンドが動作しなくなってしまった。具体的には次のようなエラーが表示される。
xcodebuild: error: developer tools not installed;
download from http://developer.apple.com

原因はこれまで/DeveloperにインストールされていたXcodeがXcode 4.3より/Applicationsにインストールされるようになったため。
これまでの/Developerに相当するものは、/Applications/Xcode.appのパッケージに内包されるようになった。

xcode-selectコマンドを使用して、Xcodeのインストール先を指定することでxcodebuildコマンドの修復に成功した。

以下手順

  1. ターミナルを開く。
  2. 以下のコマンドを入力する。
  3. sudo xcode-select -switch /Applications/Xcode.app/Contents/Developer

  4. パスワード入力が求められるので、管理者のパスワードを入力する。

参考文献
xcode-select で Xcode の保存先を変更
http://d.hatena.ne.jp/watanata2000/20111028/1319808003

追記:「iOSの教科書」印刷製本プロジェクト開始!しました。ご支援ご協力よろしくお願い申し上げます。

広告

コメントは停止中です。

%d人のブロガーが「いいね」をつけました。